Raw New Markdown
Generating updated version of doc...
Rendered New Markdown
Generating updated version of doc...
---
title: "AZFD0008: Failed to read from Blob Storage secret repository because its access tier is set to archive"
titleSuffix: "Azure Functions"
description: "Learn how to troubleshoot the event 'AZFD0008: Failed to read from Blob storage secret repository because its access tier is set to archive' in Azure Functions."
ms.topic: error-reference
ms.date: 12/01/2023
---
# AZFD0008: Failed to read from Blob Storage secret repository because its access tier is set to archive
This error happens when you set the Azure Blob Storage access tier to `archive` in the file where secrets are stored. This setting prevents the Azure Functions host from accessing key information required by certain functions.
| | Value |
|-|-|
| **Event ID** |AZFD0008|
| **Severity** |Error|
## Event description
By default, the access tier for blobs in Azure Storage is set to an online value (`hot` or `cool`). For more information, see [Set a blob's access tier](../../../storage/blobs/access-tiers-online-manage.md).
Azure Functions uses an encrypted repository file (host.json) to securely store [access keys](../../function-keys-how-to.md) (function or host) used by your function app. When the access tier of this secrets repository file is set to `archive`, functions that require access keys return an error. These functions can include HTTP triggers, Event Grid calls, and durable orchestrations.
When access keys aren't accessible because the secrets repository is in an archived state, you see a 409 warning in the logs like:
> `This operation is not permitted on an archived blob.`
## How to resolve the event
To resolve this error, change the access tier of the repository (host.json) file used by your function app back to `hot`. To learn how to set the access tier on a file, see [Set a blob's access tier](../../../storage/blobs/access-tiers-online-manage.md).
You can find the host.json file in the storage account used by your function app in a container named `azure-webjobs-secrets` in a subfolder with the same name as your function app, such as: `azure-webjobs-secrets\<FUNCTION_APP_NAME>\host.json`.
To determine the storage account used by your function app, review the [AzureWebJobsStorage](../../functions-app-settings.md#azurewebjobsstorage) application setting.
## When to suppress the event
This event shouldn't be suppressed.